Database Requirements

<< Click to Display Table of Contents >>

Navigation:  Installing EventSentry > Requirements >

Database Requirements

Database ODBC Drivers

When consolidating data to a central database, then the appropriate database ODBC drivers will need to be installed on each client that is to write to the database. No action is required when using a MSSQL Server database with Windows® 2003 (or newer) hosts, but please see the table below for more information on which ODBC drivers need to be installed.

 

Database

Windows® XP/2003, Vista/2008, Win7/2008R2,  Win 8/2012, Win 8.1/2012R2, Win 10/2016

PostgreSQL

included with EventSentry installation

Microsoft® SQL Server 2000-2016

included with Operating System

MySQL 5.x

included with EventSentry installation

Oracle®

Not Included: Download & Install Oracle ODBC drivers

 

Database Support Tiers

EventSentry supports 4 different types of SQL database servers: PostgreSQL, Microsoft® SQL Server, MySQL and Oracle®. EventSentry offers different support levels depending on the type and version of the database. These different support levels are described by their respective database tiers, shown below:

 

Tier Level

Description

Tier 1 (recommended)

Database is fully supported and has undergone extensive testing.

Tier 2

Database is supported and has undergone basic testing.

Tier 3

Database is compatible with EventSentry but not officially supported and has only undergone minimal testing. Use this database only if you have experience with it.

 

Database (optional)

A database server is required for the web-based reporting, and when consolidating event logs, system health and other information in a central database. Not all database types and versions are supported equally, the database support tier (see "Database Support Tiers" above) describes the support level of the database.

 

Database

Support Tier

PostgreSQL 9.1

2

PostgreSQL 9.6

1

Microsoft® SQL Server 2000 (with SP3a and later)

3

Microsoft® SQL Server 2005 (32-bit or 64-bit)

2

Microsoft® SQL Server 2005 Express

2

Microsoft® SQL Server 2008 (32-bit or 64-bit)

1

Microsoft® SQL Server 2008 Express

1

Microsoft® SQL Server 2008 R2 (32-bit or 64-bit)

1

Microsoft® SQL Server 2008 R2 Express

1

Microsoft® SQL Server 2012

1

Microsoft® SQL Server 2012 Express

1

Microsoft® SQL Server 2014 *

1

Microsoft® SQL Server 2014 Express *

1

Microsoft® SQL Server 2016 *

1

Microsoft® SQL Server 2016 Express *

1

Microsoft® SQL Server 2017

2

MySQL 5.0 or higher with InnoDB support

3

Oracle 9i and higher

3