What are the supported upgrade paths?

Article ID: 312
Category: Installation
Applies to: All
Updated: 2020-10-07

Please follow the steps below prior to upgrading any EventSentry installation:

  1. Save a copy of your current settings. Home > Export (3.0 and up) or File > Export (2.93 and older)
  2. Back up your database (see database vendor documentation or KB-235 for the built-in database)
  3. See below to determine if your upgrade path is supported and whether there are any specific steps or articles that must be followed before the upgrade is performed. If there are no specific steps or articles required for your upgrade path, simply run the new installer to upgrade EventSentry. If the upgrade path is supported but requires that any steps or articles be followed as preparation, perform the required steps first and then run the new installer to upgrade EventSentry.

Upgrading to 4.2 series:

4.1 to 4.2
older than 4.1: upgrade to 4.1, then upgrade to 4.2


Upgrading to 4.1 series:

4.0 to 4.1
3.5 to 4.1
3.4 to 4.1
3.3 to 4.1*
3.2 to 4.1*
3.1 to 4.1*
older than 3.1: upgrade to 3.1, then upgrade to 4.1

* Please see [KB-370] for important information regarding your web reports upgrade PRIOR to running the 4.0 series installer.


Upgrading to 4.0 series:

3.5 to 4.0
3.4 to 4.0
3.3 to 4.0*
3.2 to 4.0*
3.1 to 4.0*
3.0 to 4.0*

* Please see [KB-370] for important information regarding your web reports upgrade PRIOR to running the 4.0 series installer.


Upgrading to 3.5 series:

3.4 to 3.5
3.3 to 3.5*
3.2 to 3.5*
3.1 to 3.5*
3.0 to 3.5*

* Please see [KB-370] for important information regarding your web reports upgrade PRIOR to running the 3.5 series installer.


Upgrading to 3.4 series:
Please see [KB-370] for important information regarding your web reports upgrade PRIOR to running the 3.4 series installer.

3.3 to 3.4
3.2 to 3.4
3.1 to 3.4
3.0 to 3.4
2.93 to 3.4*
older than 2.93: upgrade to 2.93, then upgrade to 3.4*

* Microsoft SQL Server users: Read KB-311 to ensure you have enough disk space for your EventSentry database.


Upgrading to 3.3 series:

3.2 to 3.3
3.1 to 3.3
3.0 to 3.3
2.93 to 3.3*
older than 2.93: upgrade to 2.93, then upgrade to 3.3*

* Microsoft SQL Server users: Read KB-311 to ensure you have enough disk space for your EventSentry database.


Upgrading to 3.2 series:

3.1 to 3.2
3.0 to 3.2
2.93 to 3.2*
older than 2.93: upgrade to 2.93, then upgrade to 3.2*

* Microsoft SQL Server users: Read KB-311 to ensure you have enough disk space for your EventSentry database.


Upgrading to 3.1 series:

3.0 to 3.1
2.93 to 3.1
2.92 to 3.1*
2.91 to 3.1*
older than 2.91: upgrade to 2.91, then upgrade to 3.1*

* Microsoft SQL Server users: Read KB-311 to ensure you have enough disk space for your EventSentry database.


Upgrading to 3.0 series:

2.93 to 3.0
2.92 to 3.0*
2.91 to 3.0*
older than 2.91: upgrade to 2.91, then upgrade to 3.0*

* Microsoft SQL Server users: Read KB-311 to ensure you have enough disk space for your EventSentry database.


Upgrading from a version older than 3.0 series, to another version older than 3.0 series:
Please see the version-specific upgrade documentation pages by clicking to expand the "Updating to a new version" chapter in the left side of the online documentation https://www.eventsentry.com/documentation/help/html/?installationupdate.htm